import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(@[a-zA-z0-9]*|.*)(\\/.*\\/|trending.?shareId=)([\\d]*)";
final String string = "https://m.tiktok.com/h5/share/usr/6641141594707361797.html\n"
+ "https://m.tiktok.com/v/6749869095467945218.html\n"
+ "https://www.tiktok.com/@cchelseam..eow/video/6751181801206729990\n"
+ "https://www.tiktok.com/embed/6567659045795758085\n"
+ "https://www.tiktok.com/share/user/6567659045795758085\n"
+ "https://www.tiktok.com/trending?shareId=6744531482393545985";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}