using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(@[a-zA-z0-9]*|.*)(\/.*\/|trending.?shareId=)([\d]*)";
string input = @"https://m.tiktok.com/h5/share/usr/6641141594707361797.html
https://m.tiktok.com/v/6749869095467945218.html
https://www.tiktok.com/@cchelseam..eow/video/6751181801206729990
https://www.tiktok.com/embed/6567659045795758085
https://www.tiktok.com/share/user/6567659045795758085
https://www.tiktok.com/trending?shareId=6744531482393545985";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}