#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(@[a-zA-z0-9]*|.*)(\/.*\/|trending.?shareId=)([\d]*)"
Local $sString = "https://m.tiktok.com/h5/share/usr/6641141594707361797.html" & @CRLF & _
"https://m.tiktok.com/v/6749869095467945218.html" & @CRLF & _
"https://www.tiktok.com/@cchelseam..eow/video/6751181801206729990" & @CRLF & _
"https://www.tiktok.com/embed/6567659045795758085" & @CRLF & _
"https://www.tiktok.com/share/user/6567659045795758085" & @CRLF & _
"https://www.tiktok.com/trending?shareId=6744531482393545985"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")