import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\d*,*\\d*\\d)\\\\)|(\\d*,\\d*)|((\\d*)\\/)";
final String string = "1,258\\xa0sq\\xa0mi (3,260\\xa0km2)\n"
+ "45\\xa0sq\\xa0mi (120\\xa0km2) \\xa03.6%\n"
+ "234,878\n"
+ "45\\xa0sq\\xa0mi (120\\xa0km2) \\xa03.6%\n"
+ "194/sq\\xa0mi (75/km2\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}