using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d*,*\d*\d)\\)|(\d*,\d*)|((\d*)\/)";
string substitution = @"";
string input = @"1,258\xa0sq\xa0mi (3,260\xa0km2)
45\xa0sq\xa0mi (120\xa0km2) \xa03.6%
234,878
45\xa0sq\xa0mi (120\xa0km2) \xa03.6%
194/sq\xa0mi (75/km2
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}