#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((\d*,*\d*\d)\\)|(\d*,\d*)|((\d*)\/)"
Local $sString = "1,258\xa0sq\xa0mi (3,260\xa0km2)" & @CRLF & _
"45\xa0sq\xa0mi (120\xa0km2) \xa03.6%" & @CRLF & _
"234,878" & @CRLF & _
"45\xa0sq\xa0mi (120\xa0km2) \xa03.6%" & @CRLF & _
"194/sq\xa0mi (75/km2" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)