import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<[ul|ol][^>]*?style=\\\"[^>]*?)(list-style-type:[a-zA-Z0-9:\\.\\s\\(\\)\\-\\,]*;?)([^\\\"]*\\\"[^>]*?>)";
final String string = "<ul style=\"list-style-type:disc\">\n"
+ "<li>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut\n"
+ "<ul style=\"list-style-type:circle\">\n"
+ "<li>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</li>\n"
+ "<li>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</li>\n"
+ "<li>In voluptate velit esse cillum dolore eu fugiat nulla pariatur.\n"
+ "<ul style=\"list-style-type:square\">\n"
+ "<li>Excepteur sint occaecat cupidatat non proident.</li>\n"
+ "<li>Sunt in culpa qui officia deserunt mollit anim id est laborum.</li>\n"
+ "</ul>\n"
+ "<ul style=\"list-style-type:square; abc:asd; qwe:10pt\">\n"
+ "<ul style=\"aaa:eeee; list-style-type:square; abc:asd; qwe:10pt\" asdas=\"aeee\">\n"
+ "<ul asdsa=\"eee\" style=\"aaa:eeee; list-style-type:square; abc:asd; qwe:10pt\" asdas=\"aeee\">\n\n"
+ "<ul style=\"list-style-type:circle;\"><li cke:reset=\"1\" cke:indent=\"1\" cke:listsymbol=\"o\" style=\"\"><span></span><span>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</span><ul style=\"list-style-type:square;\"><li cke:indent=\"2\" cke:listsymbol=\"§\" style=\"\"><span></span><span>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</span></li><li cke:indent=\"2\" cke:listsymbol=\"§\" style=\"\"><span></span><span>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</span></li><li cke:indent=\"2\" cke:listsymbol=\"§\" style=\"\"><span></span><span>In voluptate velit esse cillum dolore eu fugiat nulla pariatur. </span><ul style=\"list-style-type:disc;\"><li cke:indent=\"3\" cke:listsymbol=\"·\" style=\"\"><span></span><span>Excepteur sint occaecat cupidatat non proident.</span></li><li cke:indent=\"3\" cke:listsymbol=\"·\" style=\"\"><span></span><span>Sunt in culpa qui officia deserunt mollit anim id est laborum.</span></li></ul></li></ul></li><li cke:indent=\"1\" cke:listsymbol=\"o\" style=\"\"><span></span><span>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</span><ul style=\"list-style-type:square;\"><li cke:indent=\"2\" cke:listsymbol=\"§\" style=\"\"><span></span><span>In voluptate velit esse cillum dolore eu fugiat nulla pariatur.\n"
+ "<ol style=\"list-style-type:lower-roman;\"> ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}