#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(<[ul|ol][^>]*?style=\"[^>]*?)(list-style-type:[a-zA-Z0-9:\.\s\(\)\-\,]*;?)([^\"]*\"[^>]*?>)"
Local $sString = "<ul style="list-style-type:disc">" & @CRLF & _
"<li>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut" & @CRLF & _
"<ul style="list-style-type:circle">" & @CRLF & _
"<li>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</li>" & @CRLF & _
"<li>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</li>" & @CRLF & _
"<li>In voluptate velit esse cillum dolore eu fugiat nulla pariatur." & @CRLF & _
"<ul style="list-style-type:square">" & @CRLF & _
"<li>Excepteur sint occaecat cupidatat non proident.</li>" & @CRLF & _
"<li>Sunt in culpa qui officia deserunt mollit anim id est laborum.</li>" & @CRLF & _
"</ul>" & @CRLF & _
"<ul style="list-style-type:square; abc:asd; qwe:10pt">" & @CRLF & _
"<ul style="aaa:eeee; list-style-type:square; abc:asd; qwe:10pt" asdas="aeee">" & @CRLF & _
"<ul asdsa="eee" style="aaa:eeee; list-style-type:square; abc:asd; qwe:10pt" asdas="aeee">" & @CRLF & _
"" & @CRLF & _
"<ul style="list-style-type:circle;"><li cke:reset="1" cke:indent="1" cke:listsymbol="o" style=""><span></span><span>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</span><ul style="list-style-type:square;"><li cke:indent="2" cke:listsymbol="§" style=""><span></span><span>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</span></li><li cke:indent="2" cke:listsymbol="§" style=""><span></span><span>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</span></li><li cke:indent="2" cke:listsymbol="§" style=""><span></span><span>In voluptate velit esse cillum dolore eu fugiat nulla pariatur. </span><ul style="list-style-type:disc;"><li cke:indent="3" cke:listsymbol="·" style=""><span></span><span>Excepteur sint occaecat cupidatat non proident.</span></li><li cke:indent="3" cke:listsymbol="·" style=""><span></span><span>Sunt in culpa qui officia deserunt mollit anim id est laborum.</span></li></ul></li></ul></li><li cke:indent="1" cke:listsymbol="o" style=""><span></span><span>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</span><ul style="list-style-type:square;"><li cke:indent="2" cke:listsymbol="§" style=""><span></span><span>In voluptate velit esse cillum dolore eu fugiat nulla pariatur." & @CRLF & _
"<ol style="list-style-type:lower-roman;"> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")