using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<[ul|ol][^>]*?style=\""[^>]*?)(list-style-type:[a-zA-Z0-9:\.\s\(\)\-\,]*;?)([^\""]*\""[^>]*?>)";
string input = @"<ul style=""list-style-type:disc"">
<li>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut
<ul style=""list-style-type:circle"">
<li>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</li>
<li>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</li>
<li>In voluptate velit esse cillum dolore eu fugiat nulla pariatur.
<ul style=""list-style-type:square"">
<li>Excepteur sint occaecat cupidatat non proident.</li>
<li>Sunt in culpa qui officia deserunt mollit anim id est laborum.</li>
</ul>
<ul style=""list-style-type:square; abc:asd; qwe:10pt"">
<ul style=""aaa:eeee; list-style-type:square; abc:asd; qwe:10pt"" asdas=""aeee"">
<ul asdsa=""eee"" style=""aaa:eeee; list-style-type:square; abc:asd; qwe:10pt"" asdas=""aeee"">
<ul style=""list-style-type:circle;""><li cke:reset=""1"" cke:indent=""1"" cke:listsymbol=""o"" style=""><span></span><span>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</span><ul style=""list-style-type:square;""><li cke:indent=""2"" cke:listsymbol=""§"" style=""><span></span><span>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</span></li><li cke:indent=""2"" cke:listsymbol=""§"" style=""><span></span><span>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</span></li><li cke:indent=""2"" cke:listsymbol=""§"" style=""><span></span><span>In voluptate velit esse cillum dolore eu fugiat nulla pariatur. </span><ul style=""list-style-type:disc;""><li cke:indent=""3"" cke:listsymbol=""·"" style=""><span></span><span>Excepteur sint occaecat cupidatat non proident.</span></li><li cke:indent=""3"" cke:listsymbol=""·"" style=""><span></span><span>Sunt in culpa qui officia deserunt mollit anim id est laborum.</span></li></ul></li></ul></li><li cke:indent=""1"" cke:listsymbol=""o"" style=""><span></span><span>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</span><ul style=""list-style-type:square;""><li cke:indent=""2"" cke:listsymbol=""§"" style=""><span></span><span>In voluptate velit esse cillum dolore eu fugiat nulla pariatur.
<ol style=""list-style-type:lower-roman;""> ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}