// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(([^-<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([^-][a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$"#).unwrap();
let string = "em-ail@domain.com
email@111.222.333.44444
email@-domain.com
email.@domain.com
email..email@domain.com
email@domain..com
0121211@gmail.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}