const regex = /^(([^-<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([^-][a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([^-<>()\\[\\]\\\\.,;:\\s@"]+(\\.[^<>()\\[\\]\\\\.,;:\\s@"]+)*)|(".+"))@((\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}])|(([^-][a-zA-Z\\-0-9]+\\.)+[a-zA-Z]{2,}))$', 'gm')
const str = `em-ail@domain.com
email@111.222.333.44444
email@-domain.com
email.@domain.com
email..email@domain.com
email@domain..com
0121211@gmail.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}