import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([^-<>()\\[\\]\\\\.,;:\\s@\"]+(\\.[^<>()\\[\\]\\\\.,;:\\s@\"]+)*)|(\".+\"))@((\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}])|(([^-][a-zA-Z\\-0-9]+\\.)+[a-zA-Z]{2,}))$";
final String string = "em-ail@domain.com\n"
+ "email@111.222.333.44444\n"
+ "email@-domain.com\n"
+ "email.@domain.com \n"
+ "email..email@domain.com \n"
+ "email@domain..com\n\n"
+ "0121211@gmail.com\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}