$re = '/(\w+)\s(.*)\s(TITULAR|SUPLENTE)/m';
$str = 'YECOL Martin Sosa TITULAR
FAQ FACUNDO TORRES TITULAR
CURRY10 Luis Gonzalez TITULAR
BRAN Brandon Christian Suarez TITULAR
MAXII MAXIMILIANO EZEQUIEL ARIEL MAIDANA ORTIGOZA SUPLENTE
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);