using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\s(.*)\s(TITULAR|SUPLENTE)";
string input = @"YECOL Martin Sosa TITULAR
FAQ FACUNDO TORRES TITULAR
CURRY10 Luis Gonzalez TITULAR
BRAN Brandon Christian Suarez TITULAR
MAXII MAXIMILIANO EZEQUIEL ARIEL MAIDANA ORTIGOZA SUPLENTE
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}