const regex = /(\w+)\s(.*)\s(TITULAR|SUPLENTE)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)\\s(.*)\\s(TITULAR|SUPLENTE)', 'gm')
const str = `YECOL Martin Sosa TITULAR
FAQ FACUNDO TORRES TITULAR
CURRY10 Luis Gonzalez TITULAR
BRAN Brandon Christian Suarez TITULAR
MAXII MAXIMILIANO EZEQUIEL ARIEL MAIDANA ORTIGOZA SUPLENTE
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}