re = /(?<filename>[^\/]+$)/
str = '/shared/logs/NONPR/btlp006249/wls/8.1/P/logs/applications/usageMeter-webservice-1.0.log'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end