const regex = /(?<filename>[^\/]+$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<filename>[^\\\/]+$)', 'g')
const str = `/shared/logs/NONPR/btlp006249/wls/8.1/P/logs/applications/usageMeter-webservice-1.0.log`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}