package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<filename>[^\/]+$)`)
var str = `/shared/logs/NONPR/btlp006249/wls/8.1/P/logs/applications/usageMeter-webservice-1.0.log`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}