re = /^(?<CompleteMatch>(?:(?<DateMonthYear>\d{4}-\d{2}-\d{2})T(?<Time>\d{2}:\d{2}:\d{2}(?:\.\d+)?))(?<TimeZone>Z|[\+-]\d{2}:\d{2})?)$/m
str = '2023-01-28T13:25:00.00-05:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end