import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<CompleteMatch>(?:(?<DateMonthYear>\\d{4}-\\d{2}-\\d{2})T(?<Time>\\d{2}:\\d{2}:\\d{2}(?:\\.\\d+)?))(?<TimeZone>Z|[\\+-]\\d{2}:\\d{2})?)$";
final String string = "2023-01-28T13:25:00.00-05:00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}