const regex = /^(?<CompleteMatch>(?:(?<DateMonthYear>\d{4}-\d{2}-\d{2})T(?<Time>\d{2}:\d{2}:\d{2}(?:\.\d+)?))(?<TimeZone>Z|[\+-]\d{2}:\d{2})?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<CompleteMatch>(?:(?<DateMonthYear>\\d{4}-\\d{2}-\\d{2})T(?<Time>\\d{2}:\\d{2}:\\d{2}(?:\\.\\d+)?))(?<TimeZone>Z|[\\+-]\\d{2}:\\d{2})?)$', 'gm')
const str = `2023-01-28T13:25:00.00-05:00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}