$re = '/blog\/tag\//m';
$str = 'https://shmoo.pie/blog/tag/tom
https://shmoo.pie/blog/tag/yaron';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);