using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"blog\/tag\/";
string input = @"https://shmoo.pie/blog/tag/tom
https://shmoo.pie/blog/tag/yaron";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}