package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)blog\/tag\/`)
var str = `https://shmoo.pie/blog/tag/tom
https://shmoo.pie/blog/tag/yaron`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}