re = /^(http\:\/\/|https:\/\/)?(www.)?(facebook.com\/)((@)?[\u00A0-\uD7FF\uF900-\uFDCF\uFDF0-\uFFEF0-9A-Za-z. \-%]{1,}\/?)$/i
str = 'https://www.facebook.com/Dom-Tymczasowy-Ogonki-we-Wroc%C5%82awiu-1003917939734015/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end