const regex = /^(http\:\/\/|https:\/\/)?(www.)?(facebook.com\/)((@)?[\u00A0-\uD7FF\uF900-\uFDCF\uFDF0-\uFFEF0-9A-Za-z. \-%]{1,}\/?)$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(http\\:\\\/\\\/|https:\\\/\\\/)?(www.)?(facebook.com\\\/)((@)?[\\u00A0-\\uD7FF\\uF900-\\uFDCF\\uFDF0-\\uFFEF0-9A-Za-z. \\-%]{1,}\\\/?)$', 'i')
const str = `https://www.facebook.com/Dom-Tymczasowy-Ogonki-we-Wroc%C5%82awiu-1003917939734015/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}