import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(http\\:\\/\\/|https:\\/\\/)?(www.)?(facebook.com\\/)((@)?[\\u00A0-\\uD7FF\\uF900-\\uFDCF\\uFDF0-\\uFFEF0-9A-Za-z. \\-%]{1,}\\/?)$";
final String string = "https://www.facebook.com/Dom-Tymczasowy-Ogonki-we-Wroc%C5%82awiu-1003917939734015/";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}