import Foundation
let pattern = #"(\|.+)(\|.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
High School| Undergraduate| Graduate
---|---|---
1st Prize: $1,500| 1st Prize: $1,500| 1st Prize: $1,500 2nd Prize: $1,000| 2nd Prize: $1,000| 2nd Prize: $1,000 3rd Prize: $500| 3rd Prize: $500| 3rd Prize: $500
re.findall(r"---\|", "High School| Undergraduate| Graduate ---|---|--- 1st Prize: $1,500| 1st Prize: $1,500| 1st Prize: $1,500 2nd Prize: $1,000| 2nd Prize: $1,000| 2nd Prize: $1,000 3rd Prize: $500| 3rd Prize: $500| 3rd Prize: $500")
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)