re = /(\|.+)(\|.+)/
str = 'High School| Undergraduate| Graduate
---|---|---
1st Prize: $1,500| 1st Prize: $1,500| 1st Prize: $1,500 2nd Prize: $1,000| 2nd Prize: $1,000| 2nd Prize: $1,000 3rd Prize: $500| 3rd Prize: $500| 3rd Prize: $500
re.findall(r"---\\|", "High School| Undergraduate| Graduate ---|---|--- 1st Prize: $1,500| 1st Prize: $1,500| 1st Prize: $1,500 2nd Prize: $1,000| 2nd Prize: $1,000| 2nd Prize: $1,000 3rd Prize: $500| 3rd Prize: $500| 3rd Prize: $500")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end