$re = '/(\|.+)(\|.+)/';
$str = 'High School| Undergraduate| Graduate
---|---|---
1st Prize: $1,500| 1st Prize: $1,500| 1st Prize: $1,500 2nd Prize: $1,000| 2nd Prize: $1,000| 2nd Prize: $1,000 3rd Prize: $500| 3rd Prize: $500| 3rd Prize: $500
re.findall(r"---\\|", "High School| Undergraduate| Graduate ---|---|--- 1st Prize: $1,500| 1st Prize: $1,500| 1st Prize: $1,500 2nd Prize: $1,000| 2nd Prize: $1,000| 2nd Prize: $1,000 3rd Prize: $500| 3rd Prize: $500| 3rd Prize: $500")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);