re = /^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)$Oracle Software Owner for Each Oracle Software Product
You can create a single user (for example, oracle) to own both Oracle Database, and
Oracle Restart installations.
However, Oracle recommends that you create one software owner to own each Oracle
software installation (typically, oracle, for the database software and grid for the
Oracle Restart owner user).
You must create at least one software owner the first time you install Oracle software
on the system.
Note:
In Oracle documentation, a user created to own only Oracle Grid
Infrastructure software installations is called the grid user. A user created to
own either all Oracle installations, or only Oracle database installations, is
called the oracle user.
Standard Oracle Database Groups for Job Role Separation
Review the standard Oracle Database groups.
The following is a list of standard Oracle Database groups. These groups provide
operating system authentication for database administration system privileges:
Note:
All these groups are automatically created as a part of Oracle Database
installation on Windows.
• The OSDBA group (ORA_DBA)
Use this group the first time you install Oracle Database software on the system.
This group identifies operating system user accounts that have database
administrative privileges (the SYSDBA privilege) for all database instances running
on the server.
Members of the ORA_DBA group do not have SYSASM privileges on Oracle ASM
instances, which are needed for mounting and dismounting disk groups.
• The OSOPER group for Oracle Database (ORA_OPER)
Use this group if you want a separate group of operating system users to have a
limited set of database administrative privileges for starting up and shutting down
the database (the SYSOPER privilege).
• The OSDBA group for a particular Oracle home (ORA_HOMENAME_DBA)
This group is created the first time you install Oracle Database software into a new
Oracle home. This group identifies operating system user accounts that have
Chapter 4
Creating Required Operating System Groups and Users
4-8/
str = '10.1.1.1f'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result