#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)$Oracle Software Owner for Each Oracle Software Product" & @CRLF & _
"" & @CRLF & _
"You can create a single user (for example, oracle) to own both Oracle Database, and" & @CRLF & _
"" & @CRLF & _
"Oracle Restart installations." & @CRLF & _
"" & @CRLF & _
"However, Oracle recommends that you create one software owner to own each Oracle" & @CRLF & _
"" & @CRLF & _
"software installation (typically, oracle, for the database software and grid for the" & @CRLF & _
"" & @CRLF & _
"Oracle Restart owner user)." & @CRLF & _
"" & @CRLF & _
"You must create at least one software owner the first time you install Oracle software" & @CRLF & _
"" & @CRLF & _
"on the system." & @CRLF & _
"" & @CRLF & _
"Note:" & @CRLF & _
"" & @CRLF & _
"In Oracle documentation, a user created to own only Oracle Grid" & @CRLF & _
"" & @CRLF & _
"Infrastructure software installations is called the grid user. A user created to" & @CRLF & _
"" & @CRLF & _
"own either all Oracle installations, or only Oracle database installations, is" & @CRLF & _
"" & @CRLF & _
"called the oracle user." & @CRLF & _
"" & @CRLF & _
"Standard Oracle Database Groups for Job Role Separation" & @CRLF & _
"" & @CRLF & _
"Review the standard Oracle Database groups." & @CRLF & _
"" & @CRLF & _
"The following is a list of standard Oracle Database groups. These groups provide" & @CRLF & _
"" & @CRLF & _
"operating system authentication for database administration system privileges:" & @CRLF & _
"" & @CRLF & _
"Note:" & @CRLF & _
"" & @CRLF & _
"All these groups are automatically created as a part of Oracle Database" & @CRLF & _
"" & @CRLF & _
"installation on Windows." & @CRLF & _
"" & @CRLF & _
"• The OSDBA group (ORA_DBA)" & @CRLF & _
"" & @CRLF & _
"Use this group the first time you install Oracle Database software on the system." & @CRLF & _
"" & @CRLF & _
"This group identifies operating system user accounts that have database" & @CRLF & _
"" & @CRLF & _
"administrative privileges (the SYSDBA privilege) for all database instances running" & @CRLF & _
"" & @CRLF & _
"on the server." & @CRLF & _
"" & @CRLF & _
"Members of the ORA_DBA group do not have SYSASM privileges on Oracle ASM" & @CRLF & _
"" & @CRLF & _
"instances, which are needed for mounting and dismounting disk groups." & @CRLF & _
"" & @CRLF & _
"• The OSOPER group for Oracle Database (ORA_OPER)" & @CRLF & _
"" & @CRLF & _
"Use this group if you want a separate group of operating system users to have a" & @CRLF & _
"" & @CRLF & _
"limited set of database administrative privileges for starting up and shutting down" & @CRLF & _
"" & @CRLF & _
"the database (the SYSOPER privilege)." & @CRLF & _
"" & @CRLF & _
"• The OSDBA group for a particular Oracle home (ORA_HOMENAME_DBA)" & @CRLF & _
"" & @CRLF & _
"This group is created the first time you install Oracle Database software into a new" & @CRLF & _
"" & @CRLF & _
"Oracle home. This group identifies operating system user accounts that have" & @CRLF & _
"" & @CRLF & _
"Chapter 4" & @CRLF & _
"" & @CRLF & _
"Creating Required Operating System Groups and Users" & @CRLF & _
"" & @CRLF & _
"4-8"
Local $sString = "10.1.1.1f"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)