import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)$Oracle Software Owner for Each Oracle Software Product\n\n"
+ "You can create a single user (for example, oracle) to own both Oracle Database, and\n\n"
+ "Oracle Restart installations.\n\n"
+ "However, Oracle recommends that you create one software owner to own each Oracle\n\n"
+ "software installation (typically, oracle, for the database software and grid for the\n\n"
+ "Oracle Restart owner user).\n\n"
+ "You must create at least one software owner the first time you install Oracle software\n\n"
+ "on the system.\n\n"
+ "Note:\n\n"
+ "In Oracle documentation, a user created to own only Oracle Grid\n\n"
+ "Infrastructure software installations is called the grid user. A user created to\n\n"
+ "own either all Oracle installations, or only Oracle database installations, is\n\n"
+ "called the oracle user.\n\n"
+ "Standard Oracle Database Groups for Job Role Separation\n\n"
+ "Review the standard Oracle Database groups.\n\n"
+ "The following is a list of standard Oracle Database groups. These groups provide\n\n"
+ "operating system authentication for database administration system privileges:\n\n"
+ "Note:\n\n"
+ "All these groups are automatically created as a part of Oracle Database\n\n"
+ "installation on Windows.\n\n"
+ "• The OSDBA group (ORA_DBA)\n\n"
+ "Use this group the first time you install Oracle Database software on the system.\n\n"
+ "This group identifies operating system user accounts that have database\n\n"
+ "administrative privileges (the SYSDBA privilege) for all database instances running\n\n"
+ "on the server.\n\n"
+ "Members of the ORA_DBA group do not have SYSASM privileges on Oracle ASM\n\n"
+ "instances, which are needed for mounting and dismounting disk groups.\n\n"
+ "• The OSOPER group for Oracle Database (ORA_OPER)\n\n"
+ "Use this group if you want a separate group of operating system users to have a\n\n"
+ "limited set of database administrative privileges for starting up and shutting down\n\n"
+ "the database (the SYSOPER privilege).\n\n"
+ "• The OSDBA group for a particular Oracle home (ORA_HOMENAME_DBA)\n\n"
+ "This group is created the first time you install Oracle Database software into a new\n\n"
+ "Oracle home. This group identifies operating system user accounts that have\n\n"
+ "Chapter 4\n\n"
+ "Creating Required Operating System Groups and Users\n\n"
+ "4-8";
final String string = "10.1.1.1f";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}