re = /^[A-z0-9]+@[a-z]+\.[a-z]+$/m
str = 'valid123@email.bg
invalid*name@emai1.bg
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end