package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-z0-9]+@[a-z]+\.[a-z]+$`)
var str = `valid123@email.bg
invalid*name@emai1.bg
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}