$re = '/^[A-z0-9]+@[a-z]+\.[a-z]+$/m';
$str = 'valid123@email.bg
invalid*name@emai1.bg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);