// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\w+)\s(\d+)\s([\d+]{2}:[\d+]{2}:[\d+]{2})\s\w+.\w+\s(\w+)\[(\d+)\]").unwrap();
let string = "Jul 6 14:01:23 computer.name CRON[29440]: USER (good_user)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}