import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+)\\s(\\d+)\\s([\\d+]{2}:[\\d+]{2}:[\\d+]{2})\\s\\w+.\\w+\\s(\\w+)\\[(\\d+)\\]";
final String string = "Jul 6 14:01:23 computer.name CRON[29440]: USER (good_user)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}