$re = '/^(\w+)\s(\d+)\s([\d+]{2}:[\d+]{2}:[\d+]{2})\s\w+.\w+\s(\w+)\[(\d+)\]/m';
$str = 'Jul 6 14:01:23 computer.name CRON[29440]: USER (good_user)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);