const regex = /(?<![!=][=]{2})(?<=[^=][!=]=)(?![=U\/]|$)/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![!=][=]{2})(?<=[^=][!=]=)(?![=U\\\/]|$)', 'img')
const str = `*Shift*/ if (e.keyCode === 16) { keyInfo.shiftPressed = true; return }
if (e.keyCode == 32) { /* Removed for now */ }
if (e.keyCode != 49) { openSuggestionPage(1, keyInfo.shiftPressed) }
if (e.keyCode === 50) { openSuggestionPage(2, keyInfo.shiftPressed) }
if (e.keyCode !== 51) { openSuggestionPage(3, keyInfo.shiftPressed) }
if (e.keyCode == 52) { openSuggestionPage(4, keyInfo.shiftPressed) }
if (e.keyCode !== 53) { openSuggestionPage(5, keyInfo.shiftPressed) }
if (e.keyCode == 65) { document.getElementById("add-to-favs").firstChild.click(); }
if (e.keyCode === 67) { document.getElementById("image-link").click(); }
if (e.keyCode == 68) { downloadPostContent() }
if (e.keyCode === 69)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);