import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![!=][=]{2})(?<=[^=][!=]=)(?![=U\\/]|$)";
final String string = "*Shift*/ if (e.keyCode === 16) { keyInfo.shiftPressed = true; return }\n"
+ "if (e.keyCode == 32) { /* Removed for now */ }\n"
+ "if (e.keyCode != 49) { openSuggestionPage(1, keyInfo.shiftPressed) }\n"
+ "if (e.keyCode === 50) { openSuggestionPage(2, keyInfo.shiftPressed) }\n"
+ "if (e.keyCode !== 51) { openSuggestionPage(3, keyInfo.shiftPressed) }\n"
+ "if (e.keyCode == 52) { openSuggestionPage(4, keyInfo.shiftPressed) }\n"
+ "if (e.keyCode !== 53) { openSuggestionPage(5, keyInfo.shiftPressed) }\n"
+ "if (e.keyCode == 65) { document.getElementById(\"add-to-favs\").firstChild.click(); }\n"
+ "if (e.keyCode === 67) { document.getElementById(\"image-link\").click(); }\n"
+ "if (e.keyCode == 68) { downloadPostContent() }\n"
+ "if (e.keyCode === 69)";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}