re = /(?<=\/WEB-INF\/classes\/).*\.class/
str = '/WARonListwithJARs/WebContent/WEB-INF/classes/com/ibm/test/alan.class'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end