$re = '/(?<=\/WEB-INF\/classes\/).*\.class/';
$str = '/WARonListwithJARs/WebContent/WEB-INF/classes/com/ibm/test/alan.class';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);