const regex = /<link *.*(?: *href="([^"]*(\.png|\.ico))"| *type="(?:image\/png|image\/vnd\.microsoft\.icon|image\/x-icon)"| *rel="(?:icon|shortcut icon|apple-touch-icon)").*>/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<link *.*(?: *href="([^"]*(\\.png|\\.ico))"| *type="(?:image\\\/png|image\\\/vnd\\.microsoft\\.icon|image\\\/x-icon)"| *rel="(?:icon|shortcut icon|apple-touch-icon)").*>', 'gim')
const str = `<link rel="icon" type="image/png" href="https://static.production.thenounproject.com/img/favicons/favicon-16x16.0b6183ac3673.png" sizes="32x32" />
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}