using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<link *.*(?: *href=""([^""]*(\.png|\.ico))""| *type=""(?:image\/png|image\/vnd\.microsoft\.icon|image\/x-icon)""| *rel=""(?:icon|shortcut icon|apple-touch-icon)"").*>";
string input = @"<link rel=""icon"" type=""image/png"" href=""https://static.production.thenounproject.com/img/favicons/favicon-16x16.0b6183ac3673.png"" sizes=""32x32"" />
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}