import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<link *.*(?: *href=\"([^\"]*(\\.png|\\.ico))\"| *type=\"(?:image\\/png|image\\/vnd\\.microsoft\\.icon|image\\/x-icon)\"| *rel=\"(?:icon|shortcut icon|apple-touch-icon)\").*>";
final String string = "<link rel=\"icon\" type=\"image/png\" href=\"https://static.production.thenounproject.com/img/favicons/favicon-16x16.0b6183ac3673.png\" sizes=\"32x32\" />\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}