re = /\.\/|[a-zA-Z]+\//m
str = 'var text = \'./test\';
var baseUrl = \'http://www.example.com/\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end