$re = '/\.\/|[a-zA-Z]+\//m';
$str = 'var text = \'./test\';
var baseUrl = \'http://www.example.com/\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);