# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b\w+\b)([ ]+\1\b)+"
test_str = ("the little cat cat is in the hat hat hat, we like it.\n"
"the little cat cat is in the hat hat hat, we like it.\n"
"the little cat cat is in the hat hat hat, we like it.\n"
"the little cat cat is in the hat hat hat, we like it.\n"
"the the little cat cat is in the hat hat hat, we like it.\n"
"the the the little cat cat2 is in the hat hat hat2, we like it.\n"
"aa abb bc\n"
"ab bbc cd dc dc dc eg")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.