using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\w+\b)([ ]+\1\b)+";
string substitution = @"\1";
string input = @"the little cat cat is in the hat hat hat, we like it.
the little cat cat is in the hat hat hat, we like it.
the little cat cat is in the hat hat hat, we like it.
the little cat cat is in the hat hat hat, we like it.
the the little cat cat is in the hat hat hat, we like it.
the the the little cat cat2 is in the hat hat hat2, we like it.
aa abb bc
ab bbc cd dc dc dc eg";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}